Blank screen after Pleskupgrade

asked Feb 17 by Ciatronical (870 points)
Hey all,

after a pleskupdate I have a blank screen.

Errorlogfile says:

PHP Fatal error:  The file /var/www/vhosts/webhost.xxxxxxx.de/httpdocs/yyyyyyyy.de/plugins/api/Api.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0\n', referer: https://www.google.com/

What can I do??

Best regards
Ronny

1 Answer

answered Feb 18 by Pavel.g (4,600 points)
Hello Ronny.

You have to install ionCube Encoder. You can download it here http://www.ioncube.com/loaders.php
Or communicate with your hosting support.

Regards, Pavel.
commented Feb 19 by Ciatronical (870 points)
Hey Pavel,

Ioncube is already installed.

apt-get install --reinstall plesk-php70-ioncube-loader

root@webhost:~# locate ioncube
/opt/plesk/php/5.6/etc/php.d/00-ioncube-loader.ini
/opt/plesk/php/5.6/lib/php/modules/ioncube_loader_lin_5.6.so
/opt/plesk/php/7.0/etc/php.d/00-ioncube-loader.ini
/opt/plesk/php/7.0/lib/php/modules/ioncube_loader_lin_7.0.so
/usr/lib/php/20151012/ioncube_loader_lin_5.1.so
/usr/lib/php/20151012/ioncube_loader_lin_5.2.so
/usr/lib/php/20151012/ioncube_loader_lin_5.3.so
/usr/lib/php/20151012/ioncube_loader_lin_5.4.so
/usr/lib/php/20151012/ioncube_loader_lin_5.5.so
/usr/lib/php/20151012/ioncube_loader_lin_5.6.so
/usr/lib/x86_64-linux-gnu/php/modules/sw-engine/ioncube_loader_lin_5.6.so
/usr/local/src/ioncube
/usr/local/src/ioncube_loaders_lin_x86-64.tar.gz
/usr/local/src/ioncube/LICENSE.txt
/usr/local/src/ioncube/README.txt
/usr/local/src/ioncube/USER-GUIDE.pdf
/usr/local/src/ioncube/USER-GUIDE.txt
/usr/local/src/ioncube/ioncube_loader_lin_4.1.so
/usr/local/src/ioncube/ioncube_loader_lin_4.2.so
/usr/local/src/ioncube/ioncube_loader_lin_4.3.so
/usr/local/src/ioncube/ioncube_loader_lin_4.3_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_4.4.so
/usr/local/src/ioncube/ioncube_loader_lin_4.4_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.0.so
/usr/local/src/ioncube/ioncube_loader_lin_5.0_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.1.so
/usr/local/src/ioncube/ioncube_loader_lin_5.1_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.2.so
/usr/local/src/ioncube/ioncube_loader_lin_5.2_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.3.so
/usr/local/src/ioncube/ioncube_loader_lin_5.3_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.4.so
/usr/local/src/ioncube/ioncube_loader_lin_5.4_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.5.so
/usr/local/src/ioncube/ioncube_loader_lin_5.5_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_5.6.so
/usr/local/src/ioncube/ioncube_loader_lin_5.6_ts.so
/usr/local/src/ioncube/ioncube_loader_lin_7.0.so
/usr/local/src/ioncube/ioncube_loader_lin_7.0_ts.so
/usr/local/src/ioncube/loader-wizard.php
/var/cache/apt/archives/php-ioncube-loader_5.0.18-ubuntu16.04.16091913_amd64.deb
/var/cache/apt/archives/plesk-php56-ioncube-loader_5.0.18-ubuntu16.04.16060709_amd64.deb
/var/cache/apt/archives/plesk-php70-ioncube-loader_6.0.7-ubuntu16.04.16121313_amd64.deb
/var/lib/dpkg/info/php-ioncube-loader.conffiles
/var/lib/dpkg/info/php-ioncube-loader.list
/var/lib/dpkg/info/php-ioncube-loader.md5sums
/var/lib/dpkg/info/php-ioncube-loader.postinst
/var/lib/dpkg/info/php-ioncube-loader.postrm
/var/lib/dpkg/info/plesk-php56-ioncube-loader.conffiles
/var/lib/dpkg/info/plesk-php56-ioncube-loader.list
/var/lib/dpkg/info/plesk-php56-ioncube-loader.md5sums
/var/lib/dpkg/info/plesk-php70-ioncube-loader.conffiles
/var/lib/dpkg/info/plesk-php70-ioncube-loader.list
/var/lib/dpkg/info/plesk-php70-ioncube-loader.md5sums

You have a idea??
commented Feb 19 by Pavel.g (4,600 points)
Hello Ronny.
Could you provide a link with php information?

Use any text editor and create a file named phpinfo.php on your computer.
Edit the file and input the following code:

<?php
phpinfo();
?>

Regards, Pavel.
commented Feb 19 by Ciatronical (870 points)
commented Feb 19 by Ciatronical (870 points)
less /etc/php/7.0/fpm/conf.d/00-ioncube-loader-7.0.ini

; Important: if you experience extension loading errors after PHP upgrade, please run "dpkg-reconfigure php5-ioncube-loader" to update ionCube extension configuration
; comment out next line to disable ionCube Zend extension in php
zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so


dpkg-reconfigure plesk-php56-ioncube-loader
dpkg-reconfigure plesk-php70-ioncube-loader

no success :(
commented Feb 19 by Ciatronical (870 points)
tail -f error.log

[Tue Feb 19 19:37:22.407103 2019] [proxy_fcgi:error] [pid 15945] [client 84.150.251.223:61546] AH01071: Got error 'PHP message: PHP Warning:  is_readable(): open_basedir restriction in effect. File(/usr/share/php/ZendX/Application/Resource/Frontcontroller.php) is not within the allowed path(s): (/var/www/vhosts/webhost.yyy.de/:/tmp/) in /var/www/vhosts/webhost.yyy.de/httpdocs/xxx24.de/seotoaster_core/library/Zend/Loader.php on line 186\nPHP message: PHP Warning:  is_readable(): open_basedir restriction in effect. File(/usr/share/php/ZendX/Application/Resource/View.php) is not within the allowed path(s): (/var/www/vhosts/webhost.yyy.de/:/tmp/) in /var/www/vhosts/webhost.yyy.de/httpdocs/xxx24.de/seotoaster_core/library/Zend/Loader.php on line 186\nPHP message: PHP Warning:  is_readable(): open_basedir restriction in effect. File(/usr/share/php/ZendX/Application/Resource/Layout.php) is not within the allowed path(s): (/var/www/vhosts/webhost.yyy.de/:/tmp/) in /var/www/vhosts/webhost.yyy.de/httpdocs/xxx24.de/seotoaster_core/library/Zend/Loader.php on line 186\nPHP message: PHP Fatal error:  The file /var/www/vhosts/webhost.yyy.de/httpdocs/autoprofis24.de/plugins/api/Api.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0\n'
commented Feb 20 by Pavel.g (4,600 points)
Hello Ronny.

Please note the message
"plugins/api/Api.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0"

Regards, Pavel.
commented Feb 20 by Ciatronical (870 points)
Hey Pavel,

yes, but what can I do???

Best Regards
Ronny
commented Feb 20 by Pavel.g (4,600 points)
You can downgrade php version to 5.6 or install a new seotoster package that supports php7.
https://www.seotoaster.com/download-seotoaster-free-open-source-ecommerce-cms.html

Regards, Pavel.
commented Feb 21 by Ciatronical (870 points)
Thanks Pavel,

i will try to change any files.
...