by (140 points)
trying to install (have host gator, did update .htaccess). went to subdomain, saw this:

Seotoaster install

Step 1: System setup

Checking Server Requirements

Your server needs to meet the minimum requirements configuration in order to run the toaster.
Web server: Apache2, Nginx. Any web server that can do re-writes and support php should work too (not tested).
Fatal error: Call to undefined function apache_get_modules() in /home/jparnell/public_html/seotoaster/install/installer/views/scripts/index/step1.phtml on line 29

What... dafuq....

4 Answers

by (14.9k points)
Hello Hello,
For sure this web server is not set up properly. it seems it cannot even get past the minimum requirements screen. Are you running Apache?
by (140 points)
Yes, I am running appache. You may view the server info here:
by (2.3k points)
Hmm, it seems that your Apache works with PHP via CGI interface. That's why it sends an fatal error. We will push seotoaster package online with updated installer as soon as possible.
Follow us in social networks to hear about updates first.
by (140 points)
any idea about how long that might take?

and what's a link to your facebook?
by (2.3k points)
I think we will publish before next monday, 6th of August
by (140 points)
soooo... any word on this? would like to start testing with it... might just migrate all my sites to the toaster if it's worth it
by (2.3k points)
As you shown on screenshot you server running php 5.2.17. But SEOTOASTER requires at least php version 5.3.3 or higher.
So it's not going to work on this webserver configuration.
by (140 points)
per your instructions on the site, i have added the following to my .htaccess file:

SetEnv APPLICATION_ENV "development"
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
# Use PHP 5.3
AddHandler application/x-httpd-php53 .php .php5 .php4 .php3

as well, I have confirmed with hostgator support that by default, php 5.2 is used but they operate on php 5.2 and 5.3 in dual environments and it takes a simple .htaccess edit to enable 5.3
by (2.3k points)
Ok, then it will work. Just redownload updated package from
and try it.
by (140 points)
didn't work :(
by (140 points)
so no response to this? the updated one didn't work
by (2.3k points)
Try to download this file:
And put it in %your_seotoaster_root%/install/installer/views/scripts/index/ folder replacing existing step1.phtml file with downloaded.
by (140 points)
edited by
that's great, its actually loading now, but IonCube isnt being seen :/

(2:48:44pm)Christopher S.:Yes, your server should come with IonCube Loader already installed. Can I have a URL where you're seeing that message, please?
(2:49:07pm)Christopher S.:Thank you, just a moment please.
(2:49:14pm)Josh:sure thing
(2:49:35pm)Josh:i have to step away for a moment, ill be right back
(2:50:04pm)Christopher S.:Thanks for the heads-up. I'll keep checking into this while you're away.
(2:52:50pm)Josh:ok, im back
(2:54:40pm)Christopher S.:Thank you. I'm still checking into this for you, but it appears that IonCube Loader is installed on the server.
(2:58:00pm)Christopher S.:Thank you for standing by. I checked your phpinfo file, and I see IonCube as set up under "Additional Modules". The warning on the install page may just be a note as a general recommendation to have IonCube Installed.
(2:58:59pm)Josh:thats funny, because I installed this CMS on my lampserver and it had the Green OK when I ran the installation there after I did a manual install of IonCube
(3:00:45pm)Christopher S.:One moment please, and I'll see if I can find further information.
(3:06:43pm)Christopher S.:I apologize for the wait, Josh. I'm still checking into this for you, but shouldn't be much longer.
(3:06:56pm)Josh:ok, take you time :)
(3:14:54pm)Christopher S.:Thank you for standing by, Josh. Unfortunately, all that I'm seeing indicates that IonCube is installed and running on your server. I recommend contacting the developer of the SEO toaster software to see what they recommend, as it appears that the software is having trouble locating the module.
(3:15:10pm)Christopher S.:Here's the PHPinfo page indicating that IonCube is running:
(3:15:22pm)Christopher S.:IonCube is found under "Additional Modules"

pay no attention to the PHP version on that link, i've edited .htaccess to run 5.3
by (240 points)
I also have the same problem !
what is the solution way and where is the problem ??
by (2.3k points)
Hello bashir.

Did you tried latest package?
We put online updated package with this issue fixed yesterday (Aug 6). Try to redownload package.
If you will face same issue, can you please provide us details about your server or hosting you are using? (Such as OS, PHP/MySQL versions, WebServer software name)

Thanks for your feedback.