Disable MySQL Strict Mode

asked Oct 9 by anshul (400 points)
Hello Team,

Using Version 2.3 successfully in many websites from last 4 5 years...

Seo Toaster is great CMS... Easy to handle & very easy to use...

WITH ONE EXCEPTION... and that is a nightmare...

Please solve it... It can, will and has a problem for all others also...

-----------
Now comes to the problem...

95% of times hosting is and will be SHARED... right...

Now then, STRICT MODE is by default ON in almost all HOSTINGS...

Due to this... C H & SC SH will not work... and "Something fishy" message pops up on the screen...

Then... website is 100% working but due to this... CMS is of no use... not for me as well as for the CLIENT...
-----------

ANY SOLUTION for this...

Can't this C H & SC SH will work anyhow (means whether the strict mode of MySQL is ON or OFF) ...
POSSIBLE ??

One more Question...

Is this problem resolved in the newer versions... if YES.. i can then migrate/shift to newer versions... no problem in that...

Reference link (Answered by your team member named PAVEL.G)

https://www.seotoaster.com/questions-and-answers/7882/application-error-something-fishy-error-is-coming

Thanks in advance... waiting for the reply...

1 Answer

answered Oct 24 by seotoaster (14,500 points)
Hello,

Thank you for your message.

Kindly note that there is no need to update the version.

In this case you need to follow these instructions: https://www.liquidweb.com/kb/how-to-disable-mysql-strict-mode/

Best regards,
commented Oct 25 by anshul (400 points)
Sir,

Thank you so much for the reply...

I will do whatever is described in the reference link...

But first, i have to ask/check from the hosting provider that : is i have access to
"Command line and root level access via SSH"

if YES, then it is OK...

and if NO, then the problem will still be there...

anyway... thanks again...

I will try to convince hosting provider to give me access of
"Command line and root level access via SSH"

Thanks.
...