Unable to install due to mismatch between required PHP version and Ioncube required

asked Sep 10 by peter blackledge (120 points)
Clean install of SEOtoaster 3.0.0 on Laragon 3.1.9 (64bit PHP 7.1.14 and MySQL 5.7.19, on Windows 10) gave error message about requiring Ioncube, so installed latest version following instruction from loader-wizard.php.

This resulted in a series of entries in the PHP error log like the following.

[09-Sep-2018 15:08:23 UTC] PHP Fatal error:  The file C:\laragon\www\seotoaster\plugins\api\Api.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

So, taking the advice from an earlier question response I did a second clean install, but tried to substitute the Ioncube version for PHP 5.6. The loader-wizard.php now gives me the following error message:

The ionCube Loader is not currently installed successfully.
The following problems have been found with the ionCube Loader installation:

    The installed loader (ioncube_loader_win_5.6.dll) does not have the name expected (ioncube_loader_win_7.1.dll) for your system.
    Please check that you have the correct loader for your system.
    The installed loader is for PHP 5.6 but your server is running PHP 7.1.
    Your loader was built using VC11 but you need the loader built using VC14.
   
How do I get out of this as the SEOtoaster requirements say that it does need PHP 7?

1 Answer

answered Sep 10 by SeoToaster Support (1,040 points)
Hello Peter,

Please install 7.0 PHP version.
You will need to install a newer version of ionCube Loader 7.0 as well.

Best regards,
SeoToaster Support
commented Sep 11 by peter blackledge (120 points)
You're saying that it has to be PHP 7.0 and that the PHP 7.1 I'm running won't work??

I tried installing Ioncube for 7.1 in addition to the 5.6 version and that still gave the error "...was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1...".

Regards,
Peter
commented Sep 11 by SeoToaster Support (1,040 points)
Yes, 7.0 version for both PHP and IonCube will work fine. 7.1 and higher will be available in the next built.
...