by (120 points)
I am running a local server on linux. PHP 5.3.8. MagicQuotes is off. I get to step 3, fill out the admin name, email, and pass. Click "Toast It" and the page reloads to the same page. I have tried several times, new db each time, same result. Any ideas?

1 Answer

by (4.1k points)
Hello holljac.

Please, provide us your error.log (or whatever php error log) file contents.

If you are running the Apache web server, add this to the .htaccess file in toaster root

php_flag log_errors On
php_flag ignore_repeated_errors On
php_value error_log /path/to/yourerrolog/file

Also can you provide to us phpinfo configuration.
Thank you.
by (120 points)
I have done as you requested and then restarted the server. There was no php error log being kept so I fixed that. I dropped all tables from the db and ran the install again. Same result. No php errors are being recorded either. I hesitate to include the phpinfo since it is so long and there does not seem to be a way to attach a file, so I will only include the top part of it. If you really want more info, I can include later.


PHP Version 5.3.8

System     Linux localhost 3.2.18-pclos2.bfs #1 SMP PREEMPT Thu May 24 12:11:06 CEST 2012 x86_64
Build Date     Oct 7 2011 02:17:18
Configure Command     This is irrelevant, look inside the /usr/share/doc/php-doc/configure_command file. urpmi is your friend, use it to install extensions not shown below.
Server API     Apache 2.0 Handler
Virtual Directory Support     disabled
Configuration File (php.ini) Path     /etc
Loaded Configuration File     /etc/php.ini
Scan this dir for additional .ini files     /etc/php.d
Additional .ini files parsed     /etc/php.d/10_bz2.ini, /etc/php.d/12_ctype.ini, /etc/php.d/13_curl.ini, /etc/php.d/14_dba.ini, /etc/php.d/18_dom.ini, /etc/php.d/20ioncube.ini, /etc/php.d/21_openssl.ini, /etc/php.d/21_zlib.ini, /etc/php.d/22_ftp.ini, /etc/php.d/23_gd.ini, /etc/php.d/24_gettext.ini, /etc/php.d/25_gmp.ini, /etc/php.d/29_mbstring.ini, /etc/php.d/30_mcrypt.ini, /etc/php.d/32_fileinfo.ini, /etc/php.d/36_mysql.ini, /etc/php.d/37_mysqli.ini, /etc/php.d/39_odbc.ini, /etc/php.d/40_pcntl.ini, /etc/php.d/43_posix.ini, /etc/php.d/47_session.ini, /etc/php.d/54_hash.ini, /etc/php.d/57_sysvsem.ini, /etc/php.d/58_sysvshm.ini, /etc/php.d/59_tidy.ini, /etc/php.d/60_tokenizer.ini, /etc/php.d/62_xml.ini, /etc/php.d/63_xmlreader.ini, /etc/php.d/64_xmlwriter.ini, /etc/php.d/66_bcmath.ini, /etc/php.d/70_pdo.ini, /etc/php.d/71_pdo_dblib.ini, /etc/php.d/73_pdo_mysql.ini, /etc/php.d/75_pdo_odbc.ini, /etc/php.d/81_filter.ini, /etc/php.d/82_json.ini, /etc/php.d/83_zip.ini, /etc/php.d/A60_timezonedb.ini, /etc/php.d/Z98_suhosin.ini
PHP API     20090626
PHP Extension     20090626
Zend Extension     220090626
Zend Extension Build     API220090626,NTS
PHP Extension Build     API20090626,NTS
Debug Build     no
Thread Safety     disabled
Zend Memory Manager     enabled
Zend Multibyte Support     disabled
IPv6 Support     enabled
Registered PHP Streams     compress.bzip2, https, ftps, compress.zlib, php, file, glob, data, http, ftp, zip
Registered Stream Socket Transports     tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters     bzip2.*, zlib.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

Suhosin logo This server is protected with the Suhosin Patch 0.9.10
Copyright (c) 2006-2007 Hardened-PHP Project Copyright (c) 2007-2009 SektionEins GmbH

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
by (4.1k points)
Also can you say for us what browser you used during installation? Do you have permissions to write data at the folder seotoaster_core/application/configs ?

Thank you.
by (120 points)
This is linux, so no IE. I use firefox. I also tried chrome. Yes I have permission. I've set it up so I own all of /var/www/html. The directory seotoaster_core/application/configs is 777.
by (120 points)
Any other ideas?
by (4.1k points)
Hello holljac.

Do you have enabled strict mode on mysql? If yes try
SET @@global.sql_mode= ''; command for example in phpmyadmin.

Thank you.
by (120 points)
I ran the command in phpmyadmin, deleted all tables in the database and tried to reinstall. Still just cycles the "Toast It" screen.