Installing problem

asked Jan 18, 2013 by woohoo (120 points)
I will try to go directly to the question:

--> You can see the first step all green and ok here:

http://postimage.org/image/hbfs0migj/

--> you can see the error generated in step 2 here:

http://postimage.org/image/bh0dkducz/

I will appreciate any help on this, and thanks very much for your work.

All the best!

1 Answer

answered Jan 18, 2013 by seotoaster (14,420 points)
My Spanish is a bit rusty, but from what I gather you're unable to connect to your database. Have you tried to telnet using the same credential from this account? You probably you get the same message if you try. So first verify your credentials and connection path to the database.
commented Jan 18, 2013 by woohoo (120 points)
Hi and thanks for answering.

My credentials to connect to the database are indeed ok, I have in the same local server a few other installations (wordpress, opencart..) to try. And I tried to create a different user to the root with a different pass and I had no lucky either.

Thanks!
commented Jan 19, 2013 by seotoaster (14,420 points)
What does your /etc/hosts says? is it recognizing/mapping your localhost or hostname to 127.0.0.1?

This error is definitely a connection error, so it is either Linux is somehow not properly configured/host name not being recognized.
Check that MySQL my.cnf has the "skip-networking" option enabled, and the /etc/hosts.allow and /etc/hosts.deny files. You should have a "mysqld: ALL" in hosts.allow and nothing preventing you to connect in /etc/hosts.deny
...